NAT - pristup k portu 80 na LAN zariadeni cez public adresu nefunguje

Otázka

  • 1

dobry den mame nastavene NAT na subdomenu, v routri adb mamte nastavene prichodzie porty 80 presmeruje na nase NAS kde mame nejake subory pre partnerov. Len link funguje "iba zvonka" - ak sme na rovnakej domene a zadame link tak ako funguje zvonka, nevieme ho otvorit lebo nam ho nenacita

neviem ci to suvisi s pevnou ip, alebo s nastavenim security (ktore na routri neviem poriadne pozret v admine). Vidim len ze tam je na vstupe nejake "customSlovakNet" security nastavenie ktore neviem pozriet a nastavit a neviem ci suvisi....  na NAS sa dostanem cez lan ip adresu, ale cez http linku cez vonkajsiu subdomenu to nejde - pomohlo az ked som si nastavil v subore hosts napevno prepis subdomeny na lokalnu ip nasho NAS...

ale vseobecne, to je divne, preco to robi?

ps - v nastaveni nat som videl aj volbu hairpinning ktore by malo byt presne o tomto tusim, ale nefunguje ani ked ho zapnem, ani ked ho vypnem. takze asi bude este niekde pes zakopany.... please help

 

 

 

 

Zdieľať tento príspevok


Odkaz na príspevok
Zdieľať na iných stránkach

4 odpovede na túto otázku

  • 0

Pridal (editované)

aký tvar má ten link ?

doména, máte v doméne dns ? skús telnet s portom 80 na tú externú ip z vnútornej siete či pôjde.

 

Editoval eM Kei

Zdieľať tento príspevok


Odkaz na príspevok
Zdieľať na iných stránkach
  • 0

Pridal (editované)

 

dobry den mame nastavene NAT na subdomenu, v routri adb mamte nastavene prichodzie porty 80 presmeruje na nase NAS kde mame nejake subory pre partnerov. Len link funguje "iba zvonka" - ak sme na rovnakej domene a zadame link tak ako funguje zvonka, nevieme ho otvorit lebo nam ho nenacita

neviem ci to suvisi s pevnou ip, alebo s nastavenim security (ktore na routri neviem poriadne pozret v admine). Vidim len ze tam je na vstupe nejake "customSlovakNet" security nastavenie ktore neviem pozriet a nastavit a neviem ci suvisi....  na NAS sa dostanem cez lan ip adresu, ale cez http linku cez vonkajsiu subdomenu to nejde - pomohlo az ked som si nastavil v subore hosts napevno prepis subdomeny na lokalnu ip nasho NAS...

ale vseobecne, to je divne, preco to robi?

ps - v nastaveni nat som videl aj volbu hairpinning ktore by malo byt presne o tomto tusim, ale nefunguje ani ked ho zapnem, ani ked ho vypnem. takze asi bude este niekde pes zakopany.... please help

Sice vobec nepoznam ADB router, takze s nastavenim ti nepomozem. Ale vseobecne tvojej otazke velmi nerozumiem. Ja vlastne nemam ani NAS, ale malo by sa jednat o nejake datove ulozisko s web interfacom a nejakymi sluzbami navyse.

Ja pouzivam takmer na vsetko linuxove kontajnery, ci uz sa jedna o data-clouds, domaci ip stream a pod.

Predpokladam, ze mas nejaky NAS s web rozhranim a chces sa nan pripajat  z internetu. Zakladna poziadavka aby si sa vedel pripojit z internetu do lokalnej siete je verejna IP adresa. Ako si uz spomenul, tak na to sa pouziva NAT, ktory preklada IP adresy. Ak IP adresa nie je pevna, tak mozes vyuzit sluzby niektoreho free dyn DNS servera. Tych free dyn DNS serverov je vela, staci googlit. Z vnutra siete ak chces vyuzit dyn DNS meno, tak ako si uviedol pridas si v /etc/hosts k IP adrese aj domenove meno (to musis urobit na vsetkych PC v sieti) alebo nastavis hairpin.

Ale idealne by bolo ak by si v jednoduchosti napisal co konkretne chces

Editoval janyxx

Zdieľať tento príspevok


Odkaz na príspevok
Zdieľať na iných stránkach
  • 0

asi prave ten hairpin  je problem, skusal som ho zapnut ale nepomaha, neviem co dalej

problem je ze sharujeme partnerom nejake pracovne subory a posielame im linky vo forme   http://nieco1.nieco.sk/subor3.zip a aj im to funguje, ale z dovodu problemu s hairpinom to neviem otvorit ak som v rovnakej sieti LAN ako dane NAS. Tym padom si nevieme sami overit ci sme ozaj dali spravnu linku niekomu. Pri kliknuti z pc v rovnakej LAN sieti proste nacitava nacitava donekonecna, nenacita. Kedysi to slo neviem co sa zmenilo....

  • "zvonka" vsetko funguje, ale z rovnakej LAN nie
  • mame verejnu pevnu IP adresu, v routri nastavene NAT na NAS s web rozhranim, a vytvorene weby nieco1 a nieco2
  • v DNS na hostingu mame pre dane weby nastavene subdomeny nieco1 a nieco2.nieco.sk nasmerovane na nasu verejnu pevnu IP
  • na nasej pevnej IP sedi spomenuty ADB router
  • pri zadani adresy vo forme http://nieco1.nieco.sk ak nie som na nasej WIFI alebo LAN, sa zobrazi z NAS spravne to co ma, a JE TO OK, ale ak som na rovnakej LAN tak mi link neotvori - problem s hairpinningom zrejme

v ADB routri je checkbox "hairpin" ale nebadam ziadny rozdiel, ci uz je zakliknuty alebo nie :(

 

 

Zdieľať tento príspevok


Odkaz na príspevok
Zdieľať na iných stránkach
  • 0

Ako som spomenul, tak nemam ADB a ani som ho nikdy nekonfiguroval.

Ako funguje hairpin je velmi pekne popisane tu https://wiki.mikrotik.com/wiki/Hairpin_NAT

V podstate sa jedna o problem, ze ak je klient z vonka, tak paket od klienta ide na tvoju verejnu IP.  Ty mas nastaveny NAT na adresu NASu, cize sa paket prelozi az dorazi k NASu. NAS odosle paket na klienta az sa preluska cez router na tvoju verejnu a odosle sa klientovy. Toto som napisal velmi zjednodusene, inak je to dost komplikovany proces.

A teraz ten problem: ty odosles paket nie na NAS priamo, ale odosielas ho na verejnu IP routera, zatial vsetko funguje a NAS ti posiela odpoved z jeho LAN adresy a nie z tvojej verejnej IP adresy. Lenze ty ocakavas odpoved z verejnej adresy, tak tu odpoved zahodis. Preto ti to v LAN nefunguje.

 

Tym hairpinom by si to mal poriesit, ale neviem ako to funguje v ADB

Zdieľať tento príspevok


Odkaz na príspevok
Zdieľať na iných stránkach

Vytvor si účet alebo sa prihlás, ak chceš komentovať

Musíš byť členom, aby si mohol pridať komentár

Vytvoriť účet

Zaregistrujte si nový účet v našej komunite. Je to ľahké!


Registrácia nového účtu

Prihlásiť sa

Máš už účet? Prihlás sa tu.


Prihlásiť sa teraz

sidebar